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Overview

Introduction

The P4S-348-R2 (PHPoC Shield 2 for Arduino) is a shield that connects Arduino to a wired or
wireless network. After attaching this shield on top of the Arduino and connecting the LAN cable or
USB wireless dongle, you can connect Arduino to the Internet by simply setting up the network.

The network function of this shield is based on the TCP/IP stack using PHPoC interpreter. The shield
can be easily accessed by PHPoC Library. PHPoC Library is very similar to the usage of Arduino
Ethernet library. Therefore, source codes using existing Ethernet library can be used immediately
after modifying just few lines. Furthermore, Phpoc Library has a wider range of applications since it
supports a variety of API(TELNET, Web socket and ESMTP).

Unlike the existing PHPoC Shield (P4S-348), the P4S-348-R2 is equipped with an SPC port for
communication with the Smart Expansion Boards for Shield 2, which provides a wide range of
applications.

※ What is smart expansion boards for Shield 2?

Features

Equipped with SPC port: for smart expansion boards for Shield 2
Network Shield for Arduino (Compatible boards: Uno and Mega)
Communication with Arduino by SPI
Power: DC 5V (Supplied from Arduino boards)
Network controller: PHPoC interpreter
Ethernet: 10/100Mb
Wireless LAN: IEEE802.11b/g
WLAN security: WPA-PSK/Enterprise
Web settings (Smartphone or PC)
Embedded web applications: Web Serial monitor, Web Serial Plotter, Web Remote control
(Push, Slide and Pad)
Save time information (RTC - Battery Backup)

https://www.phpoc.com/phpoc_shield.php
https://www.phpoc.com/phpoc_shield_R1.php
https://www.phpoc.com/expansion_board_for_phpoc_shield.php
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Support IPv6

Protocol Stack
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Hardware Specifications

Block Diagram

Dimension

The dimensions of P4S-348-R2 are as follows: (Unit: mm)



P4S-348-R2 User Manual > Hardware Specifications

2018-11-30 Sollae Systems page 4 of 72

Weight

The weight is about 28.6g(without USB Wireless LAN dongle).

Communication with Arduino

PHPoC Shield for Arduino communicates to Arduino via SPI through ICSP header. SPI interface of
the Arduino Uno and Mega is as follows:

Pin Uno Mega
MOSI 11 51
MISO 12 50
CLK 13 52
SS 10 10

On the Mega, the pin 53 must be kept as an output or the SPI interface won't
work.

Connectors & Components

Ethernet Port1.

It supports 10M/100Mbit Ethernet.

Micro USB Port2.

It is a reserved port.
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USB Port3.

It supports IEEE 802.11b/g wireless LAN. Connect a USB WIFI dongle to this port.

You must use a USB WIFI dongle equipped with Ralink RT3070 or RT5370
chipset.

MicroSD Socket4.

It provides a microSD card socket. Arduino directly communicates with SD memory through
SPI. The SS pin of SPI for selecting SD memory communication is 4.

Built-in Battery5.

It provides a built-in battery for RTC features and saving log information.

SETUP Button6.

It is used to change or to initialize environment values to default value.

RESET Button7.

This button is for product reset.

SPC Port8.

It is for communication with smart expansions for PHPoC shields.

LED Indicators

This shield has 4 LEDs to indicate the status.

ON: shows that power is being supplied to the shield
STATUS: indicates the operating state of the shield

Operation - toggle ON/OFF with the same duration
Others - blinks every second

WIFI: indicates the wireless LINK state; blinks during data transmission/reception
Ethernet: displays Ethernet LINK status; blinks during data transmission/reception
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Schematic

This is the schematic of P4S-348-R2.

the schematic of P4S-348-R2 : P4S-348-R2-PO.pdf

https://www.phpoc.com/support/manual/p4s-348-r2_user_manual/img/P4S-348-R2-PO.pdf
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First Use (Web Serial Monitor)

The following is the process of monitoring the serial port of the Arduino using a mobile. If you are
new to PHPoC Shield for Arduino, do step by step.

First Use

Connect the shield to your Arduino.1.

Insert a USB Wi-Fi dongle to the shield.2.

Connect the Arduino to your PC with a USB cable.3.
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Run Arduino IDE on your PC.4.

Write a sketch below5.

void setup(){
Serial.begin(9600);
}

void loop(){
Serial.println("Hello PHPoC Shield for Arduino!");
delay(1000);
}

Upload the sketch to your Arduino.6.

With your mobile, connect to the wireless network starting with "phpoc_".7.
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Run a web browser once it is properly connected to the wireless LAN.8.

Connect to the shield by entering "192.168.0.1" in the address bar.9.

Select "Web Serial Monitor" on the main page.10.
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Press the "Connect" button.11.

Once the connection is established, you can monitor the serial port of Arduino.12.
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Set for the First Time

The existing Arduino Ethernet and WIFI shields set IP address and MAC address in the source codes.
Unlike those shields, P4S-348-R2 provides a function which manages environment parameters
related to the network of the shield itself.

Here is how to set up parameters related to wired/wireless network on PHPoC Shield for Arduino for
the first time. A mobile phone or a laptop is required for the settings.

Set for The First Time

Connect the shield to your Arduino.1.

Input power to the Arduino.2.
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Insert a USB WIFI dongle to the shield.3.

Push SETUP button on the shield once.4.

With your mobile(or laptop), connect to the wireless network starting with "phpoc_".5.
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Run a web browser once it is properly connected to the wireless LAN.6.

Connect to the shield by entering "192.168.0.1" in the address bar.7.

Move to the SETUP page by clicking the "Setup" image.8.

You can set network, time and web application parameters on this page.9.
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Connecting to an AP

Infrastructure mode is the most common wireless LAN mode that connects wireless networks around
an AP(Access Point). Set this mode to connect the shield to your local network or the Internet.

Connect Shield to an AP

Connect to the web setup page of shield according to the instructions of Set for the First1.
Time.

Move to the SETUP page.2.

https://www.phpoc.com/support/manual/p4s-348-r2_user_manual/contents.php?id=network_first_setup
https://www.phpoc.com/support/manual/p4s-348-r2_user_manual/contents.php?id=network_first_setup
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Click the [NETWORK] > [Wi-Fi] menu.3.
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Press the [Search] button of [SSID] after selecting the [Wi-Fi Mode] to [Infrastructure].4.
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Choose an AP on the list and press the [Select] button.5.

Input the Wi-Fi password to the [Shared Key] box and click the [SAVE].6.
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Setting is done if the message is shown.7.

Refer to the instruction of Manual IP setup, if you want to use a static IP
address.

https://www.phpoc.com/support/manual/p4s-348-r2_user_manual/contents.php?id=network_ip_static
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Operating as an AP

To operate the shield as an AP, you must set the wireless LAN mode to Soft AP. Soft AP is a mode
for creating a 1: 1 wireless network between a mobile device (or laptop) and a shield. The shield acts
like an AP when in this mode, so you can connect your mobile device with a shield via wireless LAN.

※Caution : You CANNOT connect the shield to the Internet in this mode. When you want to connect
your shield to the Internet, follow the instruction of Connecting to an AP.

Operating as an AP

Connect to the web setup page of shield according to the instructions of Set for the First1.
Time.

Move to the SETUP page.2.

https://www.phpoc.com/support/manual/p4s-348-r2_user_manual/contents.php?id=network_infra
https://www.phpoc.com/support/manual/p4s-348-r2_user_manual/contents.php?id=network_first_setup
https://www.phpoc.com/support/manual/p4s-348-r2_user_manual/contents.php?id=network_first_setup


P4S-348-R2 User Manual > Connecting to Network > Operating as an AP

2018-11-30 Sollae Systems page 22 of 72

Click the [NETWORK] > [Wi-Fi] menu.3.
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Press the [Search] button of [Channel] after selecting the [Wi-Fi Mode] to [Soft AP].4.
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Choose a channel which is not busy on the list and press the [Select] button.5.
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Input a name of wireless LAN in [SSID] box and click the [SAVE].6.
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Setting is done if the message is shown.7.

Search the SSID and connect your mobile to it.8.
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Run a web browser and connect to 192.168.0.1.9.
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Connecting to the Ethernet

The shield can be connected to the Ethernet if any one of those two conditions are followed:

If wireless LAN is set to "disable"
If no USB dongle is connected to the shield.

Connecting to the Ethernet

Connect LAN cable to the shield without connecting a USB WLAN dongle.1.

Check the IP address according to the instructions of Verifying the IP Address.2.

Refer to the instruction of Manual IP setup, if you want to use a static IP
address.

https://www.phpoc.com/support/manual/p4s-348-r2_user_manual/contents.php?id=network_ipcheck
https://www.phpoc.com/support/manual/p4s-348-r2_user_manual/contents.php?id=network_ip_static
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Auto IP Address

If there is a device assigning the IP address such as router on your local network, the shield can be
automatically assigned an IP address.

Connect to the web setup page of shield1.

Move to the SETUP page.2.
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Click the [NETWORK] > [IPv4] menu.3.
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Select the [IP Address Type] to [Auto IP Address] and click the [SAVE].4.
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After rebooting for finishing the settings, the shield will be assigned an IP address.5.

To confirm the assigned IP address, follow the instructions of Verifying the IP Address.6.

https://www.phpoc.com/support/manual/p4s-348-r2_user_manual/contents.php?id=network_ipcheck
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Static IP Address

You can set a static IP address to the shield as follows:

Connect to the web setup page of shield1.

Move to the SETUP page.2.
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Click the [NETWORK] > [IPv4] menu.3.
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Select the [IP Address Type] to [Static IP Address].4.
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Input an IP address, a Subnet mask, a Gateway IP address and a DNS IP address and click the5.
[SAVE].
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The IP address must be unique within the network. If you connect the
shield to a public network, please make sure whether IP address is already
in use or not. If there is a manager in charge of IP address assignment on
your network, we recommend to get assistance from the manager.

Once the setup is completed, the web browser will be reconnected to its IP address.6.
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Verifying the IP Address

Connect a shield to your network.1.

Run the Arduino IDE.2.

Input the code as follows:3.

#include <Phpoc.h>

void setup() {
  Serial.begin(9600);
  while(!Serial)
    ;

  Phpoc.begin(PF_LOG_NET);
}

void loop() {
}

Upload the code to Arduino.4.

Run the serial monitor.5.

Verify the IP address shown on the serial monitor.6.
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Library Overview

PHPoC Library

PHPoC Library is a library for Arduino which is provided for users to easily use many functions of
PHPoC shields. By using the library, you can implement many functions as follows:

TCP Client
TCP Server: web socket and TELNET server
sending an E-mail
setting Time

PHPoC Expansion Library

PHPoC Expansion Libary is a library for Arduino which is provided for users to use smart expansion
boards for Shields 2.

※ What is smart expansion boards for Shields 2?

https://www.phpoc.com/expansion_board_for_phpoc_shield.php


P4S-348-R2 User Manual > Using Library > Installing the Library

2018-11-30 Sollae Systems page 42 of 72

Installing Library

You can install the PHPoC library via Arduino IDE.

Run the Arduino IDE.1.

Click the [Sketch] > [Include Library] > [Manage Libraries...] menu.2.

Search "phpoc" on the Library Manager.3.

Select the PHPoC library and press the [Install] button.4.
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"INSTALLED" message will appear on success.

Confirm the "PHPoC" in the [Scketch] > [Include Library] > [Contributed libraries].5.

Confirm the "PHPoC" in the [File] > [Examples] > [Examples from Custom Libraries].6.

To run the examples of PHPoC library, follow the instructions of Using the Example.7.

※ Note : PHPoC Expansion library can be installed in the same way.

https://www.phpoc.com/support/manual/p4s-348-r2_user_manual/contents.php?id=library_run
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Using Examples

Examples included in the PHPoC library can be run via Arduino IDE. Here is the procedure for
running the Web Client. Note that you need to connect your shield to the Internet before running
this example.

Connect your shield to an AP which has the Internet connectivity according to the instructions1.
of Connecting to an AP.

Install the PHPoC library according to the instructions of Installing The Library.2.

Run the Aduino IDE and select [File] > [Examples] > [PHPoC] > [WebClient].3.

Upload the example.4.

Run the serial monitor.5.

Check the result shown in the serial monitor.6.

https://www.phpoc.com/support/manual/p4s-348-r2_user_manual/contents.php?id=network_infra
https://www.phpoc.com/support/manual/p4s-348-r2_user_manual/contents.php?id=library_setup
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Web Serial Monitor

Serial monitor is a function that is provided by Arduino IDE. This shield provides web serial monitor
which is the web based serial monitor. Because this function is web based, you just need a web
browser instead of USB connection to use this function.

Using Web Serial Monitor

Connect a shield to your local network.1.

Install the PHPoC library follow the instructions of Installing the Library.2.

Run the Arduino IDE.3.

Input the code as follows:4.

void setup(){
Serial.begin(9600);
}

void loop(){
Serial.println("Hello PHPoC Shield for Arduino!");
delay(1000);
}

Upload the code.5.

Run the serial monitor.6.

Check the messages on the serial monitor.7.

https://www.phpoc.com/support/manual/p4s-348-r2_user_manual/contents.php?id=library_setup
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Run a web browser on your mobile or PC and connect to the web page of the shield.8.

Follow the instruction of Verifying IP Address, if you don't know the IP
address.

Click the [Web Serial Monitor].9.

Click the [Connect] button.10.

https://www.phpoc.com/support/manual/p4s-348-r2_user_manual/contents.php?id=network_ipcheck
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The same messages will be shown with those of the serial monitor.11.
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Web Serial Plotter

Serial plotter is a function that is provided by Arduino IDE. This shield provides web serial plotter
which is the web based serial plotter. Because this function is web based, you just need a web
browser instead of USB connection to use this function.

Using Web Serial Plotter

Connect a shield to your local network.1.

Install the PHPoC library follow the instructions of Installing the Library.2.

Run the Arduino IDE.3.

Load the [WebSerialPlotter] example.4.

Upload the example code.5.

https://www.phpoc.com/support/manual/p4s-348-r2_user_manual/contents.php?id=library_setup
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Run the serial plotter.6.

Check the result in the serial plotter.7.

Run a web browser on your mobile or PC and connect to the web page of the shield.8.

Follow the instruction of Verifying IP Address, if you don't know the IP
address.

https://www.phpoc.com/support/manual/p4s-348-r2_user_manual/contents.php?id=network_ipcheck
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Click the [Web Serial Plotter].9.

Click the [Connect] button.10.

The same result will be shown with those of the serial plotter.11.
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Web Remote Control(Push)

Using the web remote control, you can control Arduino remotely by sending specific data to the
Arduino on the Web. This application provides sending data by buttons on a web browser to your
Arduino.

Using the Web Remote Control(Push)

Connect a shield to your local network.1.

Install the PHPoC library follow the instructions of Installing the Library.2.

Run the Arduino IDE.3.

Load the [WebRemotePush] example.4.

Upload the example code.5.

https://www.phpoc.com/support/manual/p4s-348-r2_user_manual/contents.php?id=library_setup
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Run the serial monitor.6.

Check the IP address of the shield.7.

Run a web browser on your mobile or PC and connect to the web page of the shield.8.

Click the [Web Remote Control / Push].9.
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Click the [Connect] button.10.

Press any of the A, B and C buttons.11.
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Check the messages on the serial monitor.12.

This example only processes for these three buttons (A, B, C). Add the rest of
buttons to Arduino codes yourself.
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Web Remote Control(Slide)

Using the web remote control, you can control Arduino remotely by sending specific data to the
Arduino on the Web. This application provides sending data by slide bars on a web browser to your
Arduino.

Using Web Remote Control (Slide)

Connect a shield to your local network.1.

Install the PHPoC library follow the instructions of Installing the Library.2.

Run the Arduino IDE.3.

Load the [WebRemoteSlide] example.4.

Upload the example code.5.

https://www.phpoc.com/support/manual/p4s-348-r2_user_manual/contents.php?id=library_setup
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Run the serial monitor.6.

Check the IP address of the shield.7.

Run a web browser on your mobile or PC and connect to the web page of the shield.8.

Click the [Web Remote Control / Slide].9.
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Click the [Connect] button.10.

Press any of the A, B and C buttons.11.
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Check the messages on the serial monitor.12.
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Web Remote Control(Pad)

Using the web remote control, you can control Arduino remotely by sending specific data to the
Arduino on the Web. This application provides sending data by a pad on a web browser to your
Arduino.

Using the Web Remote Control(Pad)

Connect a shield to your local network.1.

Install the PHPoC library follow the instructions of Installing the Library.2.

Run the Arduino IDE.3.

Load the [WebRemotePad] example.4.

Upload the example code.5.

https://www.phpoc.com/support/manual/p4s-348-r2_user_manual/contents.php?id=library_setup
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Run the serial monitor.6.

Check the IP address of the shield.7.

Run a web browser on your mobile or PC and connect to the web page of the shield.8.

Click the [Web Remote Control / Pad].9.
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Click the [Connect] button.10.
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Click or drag your mouse on the pad.11.

Check the messages on the serial monitor.12.
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Setting the Time

This shield provides an RTC function for time information. With the built-in battery mounted on the
shield, it maintains the time information even when the power is turned off.

Because of the built-in battery charging system, the battery is charged
whenever the power is connected to the shield. However, if you do not connect
power to shield for a long period (about 30 days in full-charged), the battery is
discharged and time information may be initialized.

Setting the Time

Connect to the web setup page of shield.1.

Move to the SETUP page.2.
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Click the [TIME SYNC.] on the [TIME] tap.3.
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Check the [PHPoC Shield Time] is synchronized with the [Host Local Time].4.
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Settings for Web Applications

You can set parameters of web applications.

Setting parameters of web applications

Connect to the web setup page of shield.1.

Move to the SETUP page.2.
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Click an application which you want to set on the [APP] tap.3.
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Setting Parameters

Web Serial Monitor

parameter description
Baud Rate baud rate(9600 ~ 115200bps)
Width width of the area(px)
Height height of the area(px)

Web Serial Plotter

parameter description
Baud Rate baud rate(9600 ~ 115200bps)
Size Type types of size(Fixed Size or Full Screen)
Width width of the area(px)
Height height of the area(px)
Max Sample the number of maximum samples
Y-Axis Auto Scale types of auto scale on Y-axis(Fixed or Auto Scale)
Y-Fixed Min Bound maximum value of Y-axis
Y-Fixed Max Bound minimum value of Y-axis
X-Axis Title the title of X-axis



P4S-348-R2 User Manual > Other Settings > Settings for Web Apllications

2018-11-30 Sollae Systems page 72 of 72

parameter description
Y-Axis Title the title of Y-axis

Web Remote Control(Push)

parameter description
Width width of the area(px)
Button names of buttons, only appears if it has a name

Web Remote Control(Slide)

parameter description
Width width of the area(px)
Length height of the area(px)
Max value maximum value
Min value minimum value

Web Remote Control(Pad)

parameter description
Width width of the area(px)
Height height of the area(px)
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